Plant Facility IncidentOperational

Components

Internet, Special Access

Locations

Leoti, Marienthal, Scott City, Network Operations Center



February 1, 2025 7:38AM CST
[Resolved] We have completed all repairs and all services have been restored. Thank you for your patience.

February 1, 2025 6:52AM CST
[Monitoring] Crews have completed placing a new section of fiber cable and have completed most of the splicing. All residential services have been restored and the vast majority of business services. We are expected to be 100% complete within the next 45 minutes. Thank you for your patience.

February 1, 2025 2:37AM CST
[Identified] Plant facilities that Pioneer Communications utilize to deliver service to our customers have been negatively impacted by forces beyond our control. We are currently assessing the situation. We have a damaged fiber optic cable and are facilitating repairs. We will post further updates as they become available.

Back to current status